0 votos

Hola, Soy nuevo programando en Android y hace unos dias instalé Eclipse(Mars) y las herramientas para trabajar con android(SDK ADT AVD) el problema es que cada vez que creo un proyecto nuevo tengo muchos errores. He intentado arreglarlo según información que encontraba en internet pero creo que lo empeoré...Creo que el error proviene al importarse "andoid.support.v7".Les agradecería que me ayudaran con mi problema. También he probado con Clean y Refresh muchas veces. Saludos

preguntado por Isaias Cardenas Dic 10, 2015 en Android

1 Respuesta

0 votos
Lo mejor que puedes hacer es cuando crees un proyecto elegir la versión de Android mínimo el 4.0 en adelante, así no se te debería generar las bibliotecas "android.suport"

Las bibliotecas “android.support” no las recomiendo ya que dan algunos problemas (salvo que no quede otra) y podría ser lo que te está ocasionando todo. Utiliza mejor que ActionBarActivity directamente Fragment con la biblioteca nueva; y consecuentemente en todos los métodos que ponga “Support” elimina esta palabra para poder utilizar la librería nueva. Con la nueva librería no debería de darte ningún problema.

También te recomiendo que utilices AndroidStudio para desarrollar, Eclipse ya no tiene tanto soporte.
respondido por Ramon [Admin] Dic 11, 2015